import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)(?:(?:=|:)\\w+)?$";
final String string = "https://dev.testapi.com/api/v1/properties?id:xyz&surname:kronenberg&active=true\n"
+ "https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&property_type:true\n"
+ "https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&active:true\n"
+ "https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&user_id:true\n"
+ "dev.testapi.com/api/v1/properties?id=xyz&blabla\n"
+ "dev.testapi.com/api/v1/properties?id=xyz\n"
+ "dev.testapi.com/api/v1/properties?id=xyz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}