use strict;
my $str = 'https://dev.testapi.com/api/v1/properties?id:xyz&surname:kronenberg&active=true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&property_type:true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&active:true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&user_id:true
dev.testapi.com/api/v1/properties?id=xyz&blabla
dev.testapi.com/api/v1/properties?id=xyz
dev.testapi.com/api/v1/properties?id=xyz';
my $regex = qr/(\w+)(?:(?:=|:)\w+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}