re = /(\w+)(?:(?:=|:)\w+)?$/m
str = 'https://dev.testapi.com/api/v1/properties?id:xyz&surname:kronenberg&active=true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&property_type:true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&active:true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&user_id:true
dev.testapi.com/api/v1/properties?id=xyz&blabla
dev.testapi.com/api/v1/properties?id=xyz
dev.testapi.com/api/v1/properties?id=xyz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end