import re
regex = re.compile(r"(\w+)(?:(?:=|:)\w+)?$", flags=re.MULTILINE)
test_str = ("https://dev.testapi.com/api/v1/properties?id:xyz&surname:kronenberg&active=true\n"
"https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&property_type:true\n"
"https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&active:true\n"
"https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&user_id:true\n"
"dev.testapi.com/api/v1/properties?id=xyz&blabla\n"
"dev.testapi.com/api/v1/properties?id=xyz\n"
"dev.testapi.com/api/v1/properties?id=xyz")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")