const regex = /(\w+)(?:(?:=|:)\w+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)(?:(?:=|:)\\w+)?$', 'gm')
const str = `https://dev.testapi.com/api/v1/properties?id:xyz&surname:kronenberg&active=true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&property_type:true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&active:true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&user_id:true
dev.testapi.com/api/v1/properties?id=xyz&blabla
dev.testapi.com/api/v1/properties?id=xyz
dev.testapi.com/api/v1/properties?id=xyz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}