using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/yadi\.sk\/\S+)";
string substitution = @"[link]\1[/link]";
string input = @"https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}