// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https?:\/\/yadi\.sk\/\S+)").unwrap();
let string = "https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd ";
let substitution = "[link]\\1[/link]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}