$re = '/(https?:\/\/yadi\.sk\/\S+)/m';
$str = 'https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd ';
$subst = "[link]\1[/link]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;