re = /(https?:\/\/yadi\.sk\/\S+)/m
str = 'https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd '
subst = '[link]\\1[/link]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result