import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/yadi\\.sk\\/\\S+)";
final String string = "https://yadi.sk/d/OLjfduerHJgfd\n"
+ "https://yadi.sk/d/OLjfduerHJgfd \n"
+ " https://yadi.sk/d/OLjfduerHJgfd \n"
+ "https://yadi.sk/d/OLjfduerHJgfd \n"
+ " https://yadi.sk/d/OLjfduerHJgfd \n"
+ " https://yadi.sk/d/OLjfduerHJgfd ";
final String subst = "[link]\\1[/link]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}