import re
regex = re.compile(r"(https?:\/\/yadi\.sk\/\S+)", flags=re.MULTILINE)
test_str = ("https://yadi.sk/d/OLjfduerHJgfd\n"
"https://yadi.sk/d/OLjfduerHJgfd \n"
" https://yadi.sk/d/OLjfduerHJgfd \n"
"https://yadi.sk/d/OLjfduerHJgfd \n"
" https://yadi.sk/d/OLjfduerHJgfd \n"
" https://yadi.sk/d/OLjfduerHJgfd ")
subst = "[link]\\1[/link]"
result = regex.sub(subst, test_str)
if result:
print(result)