import Foundation
let pattern = #"(https?:\/\/yadi\.sk\/\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
https://yadi.sk/d/OLjfduerHJgfd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[link]\1[/link]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)