# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'\K\.(\d+)/0$0/gm;t' <<< "$array = ['.1','1.5','0.10','.8'....];"