import re
regex = re.compile(r"'\K\.(\d+)", flags=re.MULTILINE)
test_str = "$array = ['.1','1.5','0.10','.8'....];"
subst = "0$0"
result = regex.sub(subst, test_str)
if result:
print(result)