$re = '/\'\K\.(\d+)/m';
$str = '$array = [\'.1\',\'1.5\',\'0.10\',\'.8\'....];';
$subst = "0$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;