re = /'\K\.(\d+)/m
str = '$array = [\'.1\',\'1.5\',\'0.10\',\'.8\'....];'
subst = '0$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result