using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'\K\.(\d+)";
string substitution = @"0$0";
string input = @"$array = ['.1','1.5','0.10','.8'....];";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}