const regex = /'\K\.(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'\\K\\.(\\d+)', 'gm')
const str = `\$array = ['.1','1.5','0.10','.8'....];`;
const subst = `0$0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);