#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)'\K\.(\d+)"
Local $sString = "$array = ['.1','1.5','0.10','.8'....];"
Local $sSubst = "0$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)