use strict;
my $str = '$array = [\'.1\',\'1.5\',\'0.10\',\'.8\'....];';
my $regex = qr/'\K\.(\d+)/mp;
my $subst = '0$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";