#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)http(s?)(:\/\/)((www.)?)([a-zA-z0-9\-_]+)(.com)"
Local $sString = "https://exam-ple.com" & @CRLF & _
"http://exam_ple.com" & @CRLF & _
"https://www.ex-amp_le.com" & @CRLF & _
"http://www.ex_am-ple.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")