using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http(s?)(:\/\/)((www.)?)([a-zA-z0-9\-_]+)(.com)";
string input = @"https://exam-ple.com
http://exam_ple.com
https://www.ex-amp_le.com
http://www.ex_am-ple.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}