package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http(s?)(:\/\/)((www.)?)([a-zA-z0-9\-_]+)(.com)`)
var str = `https://exam-ple.com
http://exam_ple.com
https://www.ex-amp_le.com
http://www.ex_am-ple.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}