import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http(s?)(:\\/\\/)((www.)?)([a-zA-z0-9\\-_]+)(.com)";
final String string = "https://exam-ple.com\n"
+ "http://exam_ple.com\n"
+ "https://www.ex-amp_le.com\n"
+ "http://www.ex_am-ple.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}