// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)http(s?)(:\/\/)((www.)?)([a-zA-z0-9\-_]+)(.com)").unwrap();
let string = "https://exam-ple.com
http://exam_ple.com
https://www.ex-amp_le.com
http://www.ex_am-ple.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}