const regex = /http(s?)(:\/\/)((www.)?)([a-zA-z0-9\-_]+)(.com)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http(s?)(:\\\/\\\/)((www.)?)([a-zA-z0-9\\-_]+)(.com)', 'gm')
const str = `https://exam-ple.com
http://exam_ple.com
https://www.ex-amp_le.com
http://www.ex_am-ple.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}