$re = '/http(s?)(:\/\/)((www.)?)([a-zA-z0-9\-_]+)(.com)/m';
$str = 'https://exam-ple.com
http://exam_ple.com
https://www.ex-amp_le.com
http://www.ex_am-ple.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);