use strict;
my $str = 'https://exam-ple.com
http://exam_ple.com
https://www.ex-amp_le.com
http://www.ex_am-ple.com';
my $regex = qr/http(s?)(:\/\/)((www.)?)([a-zA-z0-9\-_]+)(.com)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}