# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\d\r\n]+(\d{1,2}-\d{1,2})|.+/\1/gm;t' <<< "'dkas;6-17
'dsajdl 10'
'dsjalkdj16-20'"