using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\d\r\n]+(\d{1,2}-\d{1,2})|.+";
string substitution = @"\1";
string input = @"'dkas;6-17
'dsajdl 10'
'dsjalkdj16-20'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}