import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\d\\r\\n]+(\\d{1,2}-\\d{1,2})|.+";
final String string = "'dkas;6-17\n"
+ "'dsajdl 10'\n"
+ "'dsjalkdj16-20'";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}