#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^\d\r\n]+(\d{1,2}-\d{1,2})|.+"
Local $sString = "'dkas;6-17" & @CRLF & _
"'dsajdl 10'" & @CRLF & _
"'dsjalkdj16-20'"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)