// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^\d\r\n]+(\d{1,2}-\d{1,2})|.+").unwrap();
let string = "'dkas;6-17
'dsajdl 10'
'dsjalkdj16-20'";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}