package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\d\r\n]+(\d{1,2}-\d{1,2})|.+`)
var str = `'dkas;6-17
'dsajdl 10'
'dsjalkdj16-20'`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}