re = /[^\d\r\n]+(\d{1,2}-\d{1,2})|.+/m
str = '\'dkas;6-17
\'dsajdl 10\'
\'dsjalkdj16-20\''
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result