# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b((?:LON|LAT)\d\t)(\s-?\d+(?:\.\d+)?)\b/$1=$2/gm;t' <<< "LON1 129.97579956
LAT1 -26.33283424
LON2 130.10830688
LAT2 -26.33283424"