// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b((?:LON|LAT)\d\t)(\s-?\d+(?:\.\d+)?)\b").unwrap();
let string = "LON1 129.97579956
LAT1 -26.33283424
LON2 130.10830688
LAT2 -26.33283424";
let substitution = "$1=$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}