const regex = /\b((?:LON|LAT)\d\t)(\s-?\d+(?:\.\d+)?)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((?:LON|LAT)\\d\\t)(\\s-?\\d+(?:\\.\\d+)?)\\b', 'gm')
const str = `LON1 129.97579956
LAT1 -26.33283424
LON2 130.10830688
LAT2 -26.33283424`;
const subst = `$1=$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);