using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?:LON|LAT)\d\t)(\s-?\d+(?:\.\d+)?)\b";
string substitution = @"$1=$2";
string input = @"LON1 129.97579956
LAT1 -26.33283424
LON2 130.10830688
LAT2 -26.33283424";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}