#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b((?:LON|LAT)\d\t)(\s-?\d+(?:\.\d+)?)\b"
Local $sString = "LON1 129.97579956" & @CRLF & _
"" & @CRLF & _
"LAT1 -26.33283424" & @CRLF & _
"" & @CRLF & _
"LON2 130.10830688" & @CRLF & _
"" & @CRLF & _
"LAT2 -26.33283424"
Local $sSubst = "$1=$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)