import Foundation
let pattern = #"\b((?:LON|LAT)\d\t)(\s-?\d+(?:\.\d+)?)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
LON1 129.97579956
LAT1 -26.33283424
LON2 130.10830688
LAT2 -26.33283424
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1=$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)