package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b((?:LON|LAT)\d\t)(\s-?\d+(?:\.\d+)?)\b`)
var str = `LON1 129.97579956
LAT1 -26.33283424
LON2 130.10830688
LAT2 -26.33283424`
var substitution = "$1=$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}