import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:LON|LAT)\\d\\t)(\\s-?\\d+(?:\\.\\d+)?)\\b";
final String string = "LON1 129.97579956\n\n"
+ "LAT1 -26.33283424\n\n"
+ "LON2 130.10830688\n\n"
+ "LAT2 -26.33283424";
final String subst = "$1=$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}