# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/for [^(]+\(([^)]+)\)/for \1/g;t' <<< "Nmap scan report for ns525464.ip-8-26-94.net (8.26.94.30)
Nmap scan report for ns525465.ip-8-26-94.net (8.26.94.31)"