use strict;
my $str = 'Nmap scan report for ns525464.ip-8-26-94.net (8.26.94.30)
Nmap scan report for ns525465.ip-8-26-94.net (8.26.94.31)';
my $regex = qr/for [^(]+\(([^)]+)\)/p;
my $subst = 'for \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";