using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"for [^(]+\(([^)]+)\)";
string substitution = @"for \1";
string input = @"Nmap scan report for ns525464.ip-8-26-94.net (8.26.94.30)
Nmap scan report for ns525465.ip-8-26-94.net (8.26.94.31)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}