// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"for [^(]+\(([^)]+)\)").unwrap();
let string = "Nmap scan report for ns525464.ip-8-26-94.net (8.26.94.30)
Nmap scan report for ns525465.ip-8-26-94.net (8.26.94.31)";
let substitution = "for \\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}