package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`for [^(]+\(([^)]+)\)`)
var str = `Nmap scan report for ns525464.ip-8-26-94.net (8.26.94.30)
Nmap scan report for ns525465.ip-8-26-94.net (8.26.94.31)`
var substitution = "for \1"
fmt.Println(re.ReplaceAllString(str, substitution))
}