import Foundation
let pattern = #"for [^(]+\(([^)]+)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Nmap scan report for ns525464.ip-8-26-94.net (8.26.94.30)
Nmap scan report for ns525465.ip-8-26-94.net (8.26.94.31)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"for \1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)