#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "for [^(]+\(([^)]+)\)"
Local $sString = "Nmap scan report for ns525464.ip-8-26-94.net (8.26.94.30)" & @CRLF & _
"Nmap scan report for ns525465.ip-8-26-94.net (8.26.94.31)"
Local $sSubst = "for \1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)